All systems operational

Show current status

[Resolved] Significant service disruption

Started on September 7, 2020 at 12:54 AM. Resolved after 4 days

Affected

Connectivity
Voice
Hosting
  • Investigating
    September 7, 2020 at 12:54 AM  –  

    We are currently investigating this incident.

  • Identified
    September 7, 2020 at 1:14 AM  –  

    We have identified a DDoS (Distributed Denial of Service) effecting our upstream providers. Their engineers are working to mitigate this attack.

  • Monitoring
    September 7, 2020 at 2:02 AM  –  

    The DDoS attack has been mitigated. This issue will be kept under monitoring.

  • Identified
    September 9, 2020 at 2:26 AM  –  

    The DDoS attack has resumed and we are experiencing degraded performance across voice and internet services. Our upstream providers engineers are working to mitigate this new attack.

  • Monitoring
    September 9, 2020 at 3:35 AM  –  

    The DDoS attack has been mostly mitigated and services are returning back to operation. Our upstream providers engineers are continuing to monitor the issue.

  • Resolved
    September 11, 2020 at 4:50 AM  –  

    The DDoS attack appear to have subsided. We will keep monitoring the situation but this incident will be closed.