Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 06, 2024 - 23:00 NZST
Scheduled
As part of ongoing platform maintenance, our upstream provider will be performing a software upgrade, All South Island UFB Fibre Internet Services will have up to 2x 30min outages during the window.
Posted May 17, 2024 - 12:01 NZST
This scheduled maintenance affected: Connectivity.